Wednesday, 1 September 2010

OpenFOAM 1.7.1 is released

It is nice to read the piece of news that OpenCFD just released OpenFOAM version 1.7.1. The version optimises correctly using gcc-4.5.0 and has been verified to run on OpenSuSE-11.3.

Another good aspect is the debian packages prepared for this version, created for Ubuntu 10.04 LTS. Briefly, to install OpenFOAM in Ubuntu, execute the commands

# add the openfoam source into the source list
:/$ sudo echo "deb lucid main" >> /etc/apt/sources.list
# refresh the package list
:/$ sudo apt-get update
# Install OpenFOAM
:/$ sudo apt-get install openfoam171
# Install Paraview
:/$ sudo apt-get install paraviewopenfoam380

Please refer to this page for more information on the installation onto Ubuntu.


  1. ha! there is no binary package for other distributions, compile from source or use ubuntu - great choice! opencfd does not search for easy ways to distribute their software.

  2. Yes, it is a good reason for OpenFOAM engineers/users to turn to Ubuntu.

    Best regards,

  3. how many cluster with the latest version of ubuntu did you see?

  4. Hi zeliboba,

    I use Ubuntu on my personal computer. I am not sure if I correctly understand and reply your question :(

    Best regards,